Jump to content



Photo

Ruby 1.9.2.: Compatible With Mac Os 10.6.2?


  • Please log in to reply
2 replies to this topic

#1 Josee

Josee

    Advanced Member

  • Members
  • PipPipPip
  • 112 posts

Posted 11 July 2011 - 4:52 PM

Hello, Larry,

I just began your Ruby book this week-end and was enjoying it, when I realised that I was going to have the same problems with Ruby as with PHP: French accents and diacritics! Then I saw you mentioned Ruby 1.9 would include Unicode, and since Ruby 1.9.2 is available, I tried to install it but failed.

I'm working on an iMac with system 10.6.2. Ruby 1.8.7 is included.

I first tried to build Ruby from the source code but got the following error message (that's just a part of it, of course):

/bin/machine = unknown
/usr/bin/oslevel = unknown
/bin/universe = unknown

PATH: /usr/local/bin
PATH: /usr/local/sbin
PATH: /usr/local/mysql/bin
PATH: /usr/bin
PATH: /bin
PATH: /usr/sbin
PATH: /sbin
PATH: /usr/local/bin
PATH: /usr/X11/bin


## ----------- ##
## Core tests. ##
## ----------- ##

configure:2774: checking build system type
configure:2788: result: i386-apple-darwin10.2.0
configure:2808: checking host system type
configure:2821: result: i386-apple-darwin10.2.0
configure:2841: checking target system type
configure:2854: result: i386-apple-darwin10.2.0
configure:3079: checking for gcc
configure:3109: result: no
configure:3172: checking for cc
configure:3219: result: no
configure:3275: checking for cl.exe
configure:3305: result: no
configure:3329: error: in `/Users/xxx/ruby-1.9.2-p180':
configure:3331: error: no acceptable C compiler found in $PATH


Then I went to www.macports.org, but they say I need XCode 3.2.1 in order to install Ruby 1.9.2, and my version of XCode is only 3.1.2. On the Apple website, XCode 3.2.1 is not freely available; you must be a (paying) developer to download it. A friend tells me Mac OS 10.6.8 comes with XCode 3.2.6, but also with Ruby 1.8.7 only, so I'm wondering if it's any use upgrading the system to 10.6.8 and XCode to 3.2.6: do you know if there's some kind of incompatibility between Snow Leopard and Ruby 1.9 that would explain why it's not already installed on system 10.6.8?

Would I be better off installing Linux on my Mac (I've got a free partition waiting for it!), and then installing Ruby on the Linux partition?

With thanks in advance for your help,
  • 0

#2 Larry

Larry

    Administrator/Writer

  • Administrators
  • 3,803 posts
  • LocationState College, PA (USA)

Posted 12 July 2011 - 2:37 PM

Hey Josee,

Thanks for the interest in, and nice words on, the Ruby book. I'm glad you like it. I don't know of any incompatibilities, but included versions of languages in OSes tend to be behind. Yes, XCode does cost money now, but it's $5 (US) in the app store, so not significant.

It sounds like maybe you want to install Linux anyway. If that's the case, then go for it. Otherwise, I'd be inclined to buy the latest version of XCode and then install Ruby on the Mac.
  • 0

#3 Josee

Josee

    Advanced Member

  • Members
  • PipPipPip
  • 112 posts

Posted 12 July 2011 - 3:11 PM

Thank you for your answer, Larry. I'll probably update Snow Leopard, then, and try again downloading Ruby 1.9.2. (I'll probably install Linux some day, but just out of curiosity, so I'm in no hurry!)
  • 0